EasyBeans header

:: News

:: Mar 10, 2011 .::. 1.2.0-M4 Available

    Hello,


A new version (1.2.0-M4) of the OW2 EasyBeans product (EJB 3 container) has been released.


This version is included in the OW2 JOnAS 5.2 M5 application server.


EasyBeans can be embedded in JOnAS application server, Apache Tomcat application server, Jetty application server, on OSGi (by using EasyBeans OSGi bundles) or run in standalone mode.

EasyBeans is bundled with either Hibernate Entity Manager, Apache OpenJPA, TopLink Essentials or EclipseLink as persistence provider.
The 1.2.0-M4 release is provided with some Persistence Providers including:

  • Hibernate 3.5.6-Final (JPA 2.0 compliant)
  • OpenJPA 2.0.1 (JPA 2.0 compliant)
  • EclipseLink 2.1.2 (JPA 2.0 compliant)
  • TopLink Essentials 2.1-60f

Here are the guides:
Getting started with JOnAS 4.x (tested with 4.7.x, 4.8.x, 4.9.x and 4.10.x)
Getting started with Tomcat 5.5.x and 6.0.x (tested with 6.0.x and 7.0.x)
Getting started with Jetty 6.1.x/7.x (tested with 6.1.23 and 7.x)
Getting started with the EasyBeans OSGi bundles

Note: EasyBeans is already bundled in the OW2 JOnAS 5.2 application server.
EasyBeans is also working in standalone mode (Uberjar packages are available)

The documentation is available on the EasyBeans documentation website. (HTML or PDF)

The Release Notes are available online at : http://www.easybeans.net/xwiki/bin/view/News/Release1_2_0_M4

Download

A new EasyBeans version is out and is available in the Downloads section or in the OW2 maven repository or any maven mirror.

Download the version Now !

A Java WebStart online installer is also available  (Or try online installer without Java WebStart)

Migration

Configuration of some components has changed between 1.1.x and 1.2.x.
Check the difference before launching EasyBeans
OSGi changes : Split of the core bundle: Now there are several "small" bundles. This is more modular. Also, there are bundles for each persistence provider. EclipseLink or other persistence framework are supported (in addition to the previous support of Hibernate in OSGi mode)

Note: In OSGi mode, there is a large choice of Persistence Providers. Hibernate 3.4 or 3.5, EclipseLink 1 or EclipseLink 2 and OpenJPA 1 or OpenJPA 2 !

Mailing list

Stay tuned on EasyBeans with the easybeans-announce mailing list : http://mail.ow2.org/wws/subrequest/easybeans-announce

Release Notes:

Bug

  • (EZB-468) - Avoid a potential concurrentAccessException

Improvement

  • (EZB-462) - Use the quartz dependency org.quartz-scheduler:quartz (and upgrade quartz to 1.8.4)
  • (EZB-469) - Better handling of exception when bean class is invalid

New Feature

  • (EZB-463) - Adds ClassLoader management features

Task

  • (EZB-464) - Naming stuff should go in its own M2 module
  • (EZB-466) - Add support for java:module, java:app and java:global
  • (EZB-467) - Add Maven Integration Tests for EasyBeans by using EasyBeans Maven plugin
  • (EZB-470) - Add support for new Env-Entry elements (class, enum)
  • (EZB-471) - Update HSQLDB to 1.8.0.10
  • (EZB-472) - Update OW2 Util to 1.0.27
  • (EZB-473) - Update OW2 spec to 1.0.6
  • (EZB-474) - Update OW2 bundles to 1.0.25
Best Regards,

Florent

Log-in Register
Copyright © 2006-2011, OW2 Consortium EasyBeans Logo
Creator: benoitf  Date: 2011/03/10 12:51 Last Author: benoitf  Date: 2011/03/10 13:04
Oracle and Java are registered trademarks of Oracle and/or its affiliates. Other names may be trademarks of their respective owners.
Can’t code withoutThe best Java IDE